Forum Chasseur d'Images - www.chassimages.com


Auteur Sujet: Plus moyen d'utiliser darktable du à un problème de dépendance ...comment faire  (Lu 2888 fois)

olive36

  • Super actif
  • *
  • Messages: 1 590
Bonjours tout le monde ou ...bonsoir...tout dépend...moment ou vous ouvrirez ce fil...

Bon voilà mon problème je travaille avec gimp 2.10.10 qui ouvre mes raw avec darktable le problème c'est que darktable ne s'ouvrait plus du tout problème de dépendance ....Donc je me suis dit en le

désinstallant et en le réinstallant cela irait (toujours avec ''logiciels") mais cela n'a rien donné maintenant je ne sais même plus réinstaller Darktable (je m'y attendais ) j'ai déjà eu ce genre de

problème mais je ne sais plus comment je l'ai résolu et c'est bien pour ça que j'ai besoin d'une bonne âme pour m'aider. J'AI déjà essayé de réinstaller le programme via le terminal mais voilà ce qu'il

me répond es paquets suivants contiennent des dépendances non satisfaites :
 
darktable : Dépend: libilmbase12 (>= 2.2.0) mais il n'est pas installable
             Dépend: libopenexr22 mais il n'est pas installable
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
 
Alors si quelqu'un peu me dépanne ce serait COOL merci d'avance.

Patrick

  • Actif
  • *
  • Messages: 111
  • Sexe: Homme
Bonjour,

Quelle distribution Linux ?

Les données utilisateur (/home) sont-elles sur une partition séparée ?

Quelle version de Darktable et quelle méthode d'installation (bibliothèque de la distribution ou site spécifique) ?

Après ces questions, quelques pistes. :
si tu est sous Ubuntu ou dérivé (Mint ...) et que tu as installé à partir de la bibliothèque

sudo apt-get remove darktable

puis installation à partir du ppa :
sudo add-apt-repository ppa:pmjdebruijn/darktable-release
sudo apt-get update
sudo apt-get install darktable

si tu es sous RedHat ou dérivé : je ne sais pas !

Au pire si tes données sont dans une partition séparée une réinstallation (sans reformater le /home) et en installant darktable à partir du ppa devrait résoudre le problème.

Bien sur il faut aussi réinstaller tous les autres logiciels mais tes réglages sont conservés et cela va finalement assez vite.

Bon courage !

olive36

  • Super actif
  • *
  • Messages: 1 590
Je suis sous ubuntu 19.10 (version non définitive) ce qui n'arrange rien . J'ai accepté les versions instable dans la mise à niveau ...Je regrette mais bon ...

J'ai essayé ce que tu m'a mis mais la réponse reste la même . Je suis coincé et je vois pas comment m'en sortir. Bon je fini toujours par trouvé la solution mais pour l'instant je cale vraiment .

le problème ce sont mais raw que je n'arrive plus à développer . Et j'ai pas envie d'utiliser un sous programme (Rawthérapie) de plus je le maîtrise pas comme darktable.   

Patrick

  • Actif
  • *
  • Messages: 111
  • Sexe: Homme
Une installation via flatpak pourrait peut-être résoudre le problème de dépendances.

https://flathub.org/apps/details/org.darktable.Darktable
Mais je ne sais pas si flatpak est compatible avec Ubuntu 19.10.
Si cela ne marche pas je ne vois pas d'autre solution qu'une réinstallation (d'une version stable ! 18-04LTS ou 19-04) en sauvegardant ton dossier home s'il n'est pas dans une partition séparée.

Ceci dit s'il y a urgence Rawtherapee n'est pas si mal que cela pour dépanner.

asa100

  • Super actif
  • *
  • Messages: 535
Citer
Ceci dit s'il y a urgence Rawtherapee n'est pas si mal que cela pour dépanner.

Il est bien plus que cela, je l'ai adopté définitivement. Darktable j'ai juste l'impression que ça part dans tous les sens, j'ai vraiment du mal à trouver mes repères avec ce Soft.

Patrick

  • Actif
  • *
  • Messages: 111
  • Sexe: Homme
Il est bien plus que cela, je l'ai adopté définitivement. Darktable j'ai juste l'impression que ça part dans tous les sens, j'ai vraiment du mal à trouver mes repères avec ce Soft.

J'aurais du aller jusqu'au bout de ma phrase :
Ceci dit s'il y a urgence Rawtherapee n'est pas si mal que cela pour dépanner.... quelqu'un qui a l'habitude d'utiliser Darktable.
Après avoir testé les deux je suis plus à l'aise avec Darktable mais ce n'est qu'un avis personnel


remico

  • Hyper actif
  • *
  • Messages: 3 253
Bonjours tout le monde ou ...bonsoir...tout dépend...moment ou vous ouvrirez ce fil...

Bon voilà mon problème je travaille avec gimp 2.10.10 qui ouvre mes raw avec darktable le problème c'est que darktable ne s'ouvrait plus du tout problème de dépendance ....Donc je me suis dit en le

désinstallant et en le réinstallant cela irait (toujours avec ''logiciels") mais cela n'a rien donné maintenant je ne sais même plus réinstaller Darktable (je m'y attendais ) j'ai déjà eu ce genre de

problème mais je ne sais plus comment je l'ai résolu et c'est bien pour ça que j'ai besoin d'une bonne âme pour m'aider. J'AI déjà essayé de réinstaller le programme via le terminal mais voilà ce qu'il

me répond es paquets suivants contiennent des dépendances non satisfaites :
 
darktable : Dépend: libilmbase12 (>= 2.2.0) mais il n'est pas installable
             Dépend: libopenexr22 mais il n'est pas installable
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
 
Alors si quelqu'un peu me dépanne ce serait COOL merci d'avance.

Il y a un mode garder en l'état qui peut se désactiver.
Pour voir les paquets concernés :
sudo apt-mark showhold

Et pour débloquer la désinstallation :
sudo apt-mark unhold nom-du-paquet

Ici  libopenexr libilmbase devraient apparaitre, ou l'un ou l'autre ou même un autre logiciel dont ils sont la dépendance. S'ils ont étés marqués pour être gardés c'est que l'utilisateur l'a demandé quelquefois sans faire attention, justement en désinstallant un paquet.

Pour les paquets orphelins il y a deborphan :
https://linoxide.com/linux-how-to/remove-orphaned-packages-ubuntu/

Pour dépanner et plus simple que Rawtherapee il y a digikam aussi qui n'est pas mal.

Alouette

  • Très actif
  • *
  • Messages: 194
As-tu essayé avec le snap dans le dépot officiel d'Ubuntu ?

olive36

  • Super actif
  • *
  • Messages: 1 590
Oui j'ai essayé mais ça n'a rien donné( merci quand même ) c'était une bonne idée mais cela n'a rien donnée  . j'ai donc désinstallé Gimp car j'avais installé d'autres version de Darktable et je me

suis dis on sait jamais...mais à ma grande surprise plus moyen de réinstallé. j' ai redémarré l'ordi j'ai fais réparre paquets cassé . Je suis retourné dans ubuntu et j'ai réinstallé gimp 2.10.10 .

J'ai redémarré Gimp qui lance donc la version 2.6.2 (noir) et là à ma grande joie il ouvre la photo dans darktable  mais j'ai vite désenchanté ...et au moment de fermer Darktable il me mait :" Erreur d’appel pour la procédure «

gimp-file-load » :Erreur lors de l’ouverture du fichier « /home/nyssens/.config/GIMP/2.10/tmp/gimp-temp-21080.exr » en lecture" donc est-ce cette fois du à la version de darktable ou pas (de tout f

açon je n'avais pas le choix l'autre version ne s'installe plus) . Un truc que je ne comprend pas c'est quoi toute ces versions de

Darktable dont j'ai du mal à voir les réel différence. C'est comme Gimp 2.10.10 avec ces 2 version différente dont une ne reconnait pas le disque dur extèrne ni les carte mémoir ni gmi'c . C'est un

peu perturbant je trouve.

olive36

  • Super actif
  • *
  • Messages: 1 590
pardon j'ai vite déchanté pas désenchanté (pardon)

olive36

  • Super actif
  • *
  • Messages: 1 590
J'ai fini par renoncé pour le moment de faire fonctionné darktable et j'ai mi rawtherapee mais je suis vraiment pas convaincue . Je trouve Darktable beaucoup plus abouté et professionnel que

rawtherapee. Il y a beaucoup plus de possibilité et les rattrapage notamment des haute lumière est plus poussé . Je n'ai pas vu non plus comment augmenté la netteté, les possibilité de rattrapage

d'images sont (pour ma part beaucoup plus pointu ) bref c'est pour moi une solution de dépannage avant de remettre UBUNTU 19.04 d'ici quelque semaine .     

alafaille

  • Super actif
  • *
  • Messages: 1 018
Je suis sous ubuntu 19.10 (version non définitive) ce qui n'arrange rien ....

Remarque pas très constructive mais : en utilisant des versions "beta" de l'os on s'expose clairement à ce genre de désagréments. Si tu as besoin d'une machine stable en permanence ( ou presque) , reste sur les versions d'os stable ( ubuntu lts 18.04 ou non lts 19.04).

Si cependant tu tiens à avoir les dernières versions des logiciels avec une bonne stabilité : rolling release ( manjaro par exemple, mais il y en a bien d'autre comme l'open suse Tumbleweed).

Bon courage

remico

  • Hyper actif
  • *
  • Messages: 3 253
Remarque pas très constructive mais : en utilisant des versions "beta" de l'os on s'expose clairement à ce genre de désagréments. Si tu as besoin d'une machine stable en permanence ( ou presque) , reste sur les versions d'os stable ( ubuntu lts 18.04 ou non lts 19.04).

Si cependant tu tiens à avoir les dernières versions des logiciels avec une bonne stabilité : rolling release ( manjaro par exemple, mais il y en a bien d'autre comme l'open suse Tumbleweed).

Bon courage

Le moyen le plus simple d'avoir la dernière version de seulement deux logiciels Gimp et darktable ce n'est pas d'avoir la version instable d'ubuntu + activer les dépots de testing, mais plutôt d'avoir la version stable d'Ubuntu d'y installer les outils de développement et de recompiler (de temps à autre) la version git de ces deux logiciels et de les installer dans un répertoire spécial /opt par exemple. de cette manière il pourront cohabiter avec les version stable des mêmes logiciels qui pourront servir en cas de bug.

Ce n'est pas très compliqué un coup de sudo apt-get install build-essential pour installer les outils de développement, sudo apt-get build-dep le-paquet pour avoir les dépendances et les paquets dev, le reste est assez bien expliqué sur le site de Darktable    : https://www.darktable.org/install/
en ajoutant à la ligne cmake -DCMAKE_INSTALL_PREFIX=/opt si on ne veut rien changer au système, pour désinstaller il suffira d'effacer le fichier opt

alafaille

  • Super actif
  • *
  • Messages: 1 018
Le moyen le plus simple d'avoir la dernière version de seulement deux logiciels Gimp et darktable ce n'est pas d'avoir la version instable d'ubuntu + activer les dépots de testing, mais plutôt d'avoir la version stable d'Ubuntu d'y installer les outils de développement et de recompiler (de temps à autre) la version git de ces deux logiciels et de les installer dans un répertoire spécial /opt par exemple. de cette manière il pourront cohabiter avec les version stable des mêmes logiciels qui pourront servir en cas de bug.
C'est effectivement ce que j'ai fait , du moins pour darktable ... ( la compilation de gimp semble un peu plus pointue, je n'ai pas pris le temps de m'y pencher).

En tout cas pour darktable sous Manjaro ( base Arch Linux) la compilation à partir du dépot git marche sans souçis.
La méthode est à la fin de cette page
De temps en temps des erreurs de compilation, qui se résolvent souvent en reclonant le dépot git.
Par défaut l'installation est dans /opt et permet donc de  cohabiter avec  la version "standard dépot"

olive36

  • Super actif
  • *
  • Messages: 1 590
J'ai finalement réussi à réinstaller Darktable mais il ne se lançais toujours pas c'est en allant sur le site Darktable que j'ai réussi à corrigé l'érreur . Ce que j'avais aussi ici oublié de précisé c'est qu'il me

mettait aussi ça : /home/nyssens/.config/darktable/data.db "le fichier de verrouillage de la  base de données semble être vide" la solution était vraiment bête  IL SUFFISAIT DE VIRÉ LE FICHIER

data.db de verrouillage et le tour était joué pour celui à qui cela arrive il sait quoi faire. Maintenant je vais réfléchir à remettre Ubuntu 19.04. Mais pour l'instant tout fonctionne .

En ce qui concerne Rawthérapee mon boitier Pentax k3 II n'est vraiment pas aussi bien reconnu que sur Darktable ....Mais vu les possibilité tellement énorme de Darktable et ma maîtrise bien

qu'encore partielle de Darktable (vu ses incroyable possibilité ) je ne voudrais plus rien d'autres aujourd'hui ).   

marco56

  • Hyper actif
  • *
  • Messages: 2 772
  • Sexe: Homme
Quel intérêt de mettre ubuntu en version 19.04 ? Perso, la dernière version stable me suffit largement.

Xuolliac

  • Actif
  • *
  • Messages: 127
Bonjours,

La 19.04 et la dernière version stable d'Ubuntu  ;)

marco56

  • Hyper actif
  • *
  • Messages: 2 772
  • Sexe: Homme
Oups, je voulais dire LTS  ;D

itev

  • Très actif
  • *
  • Messages: 313
  • Sexe: Homme
    • itev_photo
Bonjour, il m'arrive d'avoir les mêmes problèmes  avec la version 2.6, dans ce cas je désinstalle tous les fichiers  avec nautilus et je réinstalle tout simplement par flatpak.